Activity Stream

Filter
Sort By Time Show
Recent Recent Popular Popular Anytime Anytime Last 7 Days Last 7 Days Last 30 Days Last 30 Days All All Photos Photos Forum Forums
Filter by: Forums Last 30 Days Clear All
  • fearless's Avatar
    Today, 09:49 AM
    fearless replied to a thread M80 in Main Forum
    Thanks, Caleb.
    4 replies | 24 view(s)
  • Caleb_Elling's Avatar
    Today, 08:35 AM
    Hey railhead, Absolutely! Just make sure to set your gain staging correctly. Feeding a super hot signal into the Session might push the Saturation...
    1 replies | 17 view(s)
  • Caleb_Elling's Avatar
    Today, 08:30 AM
    Caleb_Elling replied to a thread M80 in Main Forum
    The big difference is that the active mode has a little bit of EQ built in already. The passive mode has no EQ. You can add your own EQ to either...
    4 replies | 24 view(s)
  • railhead's Avatar
    Yesterday, 09:15 PM
    I've been doing a lot of acoustic these last few months, and I've been mainly using my LR Bags PARA DI only but I just picked up a Session DI...
    1 replies | 17 view(s)
  • fearless's Avatar
    Yesterday, 06:05 PM
    fearless replied to a thread M80 in Main Forum
    Thanks Caleb. Don't think I want to go the dual source route at this time. Simpler is better for me. I've been fussing with pickups for too long....
    4 replies | 24 view(s)
  • btoews's Avatar
    Yesterday, 04:18 PM
    fletchrs -- did you ever get the info you needed? I'm dealing with the same kind of problem, and will likely replace both the transducer and the...
    2 replies | 1949 view(s)
  • Caleb_Elling's Avatar
    Yesterday, 03:58 PM
    Hey btoews, That pickup has an extremely low output, and a very high capacitance. So plugging it directly into an amp won't give you much signal,...
    179 replies | 116619 view(s)
  • btoews's Avatar
    Yesterday, 03:45 PM
    Only left channel works on headphone, and with either headphone or amp extremely loud hum which decreases some when touching output jack plate....
    179 replies | 116619 view(s)
  • Caleb_Elling's Avatar
    Yesterday, 02:23 PM
    Caleb_Elling replied to a thread M80 in Main Forum
    Hey Kevin, If feedback is your primary concern, then a magnetic pickup is a great way to go. If you pair the M80 (in active or passive mode) with...
    4 replies | 24 view(s)
  • Caleb_Elling's Avatar
    Yesterday, 02:16 PM
    Hey RHarris, I don't have a wiring schematic that I'm able to send out, but I'll definitely try to help you figure this out. Have you checked...
    1 replies | 50 view(s)
  • fearless's Avatar
    Yesterday, 11:58 AM
    fearless started a thread M80 in Main Forum
    Hey Guys, Thinking about purchasing an M80. Never thought I would go with a magnetic but I have just about given up fighting with feedback and...
    4 replies | 24 view(s)
  • RHarris's Avatar
    12-03-2016, 12:18 AM
    I'm getting loud shorted cable kind of sound at times while playing. Checked cable its ok even changed it. Took jack out of guitar and checked it it...
    1 replies | 50 view(s)
  • MikeW's Avatar
    11-28-2016, 03:13 PM
    Caleb, I sent you an email.
    2 replies | 88 view(s)
  • Caleb_Elling's Avatar
    11-28-2016, 10:52 AM
    Hwy Mike, Why don't you shoot me an email at [email protected] I'll see what I can do to help you out.
    2 replies | 88 view(s)
  • MikeW's Avatar
    11-28-2016, 08:55 AM
    Hi, I need a couple of pads to to put on the jig so I can install an I Beam Passive in a guitar. I had installed this in another guitar. I have...
    2 replies | 88 view(s)
  • Caleb_Elling's Avatar
    11-21-2016, 10:57 AM
    Do you have enough room in the CEO7 for the iBeam? The iBeam is usually going to be significantly less reliable if you can't put it directly under...
    3 replies | 196 view(s)
  • Caleb_Elling's Avatar
    11-21-2016, 10:54 AM
    Hey JSElmore Thanks for posting. It sounds like this may take a bit more detailed troubleshooting than can easily be done here. Would you mind...
    1 replies | 100 view(s)
  • Oldghm's Avatar
    11-21-2016, 10:14 AM
    Oldghm replied to a thread Lyric in Waterloo ????? in Main Forum
    Hi Caleb I was just wondering how it would sound. Mine is an X braced model, but there is no room on the bridge plate for the mic, in front or...
    3 replies | 196 view(s)
  • Caleb_Elling's Avatar
    11-21-2016, 09:09 AM
    Hwy Oldghm, I haven't personally, but from looking at the guitar, I don't know why it wouldn't work.
    3 replies | 196 view(s)
  • ElBenja's Avatar
    11-20-2016, 02:43 PM
    Hi everyone. Im new in this forum. I got a problem with my Lyric Classical mic on my nylon guitar. Excuse my english for any mispelling. I...
    179 replies | 116619 view(s)
  • JSElmore's Avatar
    11-20-2016, 01:15 PM
    I can't get my LB6 Acoustic Guitar Pickup to work in my acoustic guitar. The guys at the music store can't figure it out either (I'm living in...
    1 replies | 100 view(s)
  • Oldghm's Avatar
    11-18-2016, 06:22 AM
    Has anybody installed a Lyric in A 00 size Waterloo??
    3 replies | 196 view(s)
  • Caleb_Elling's Avatar
    11-14-2016, 11:37 AM
    Hey Piimiguel, Have you changed out your cables yet? If the jack is good, and the internal connections to the preamp are solid, then it's...
    1 replies | 134 view(s)
  • Piimiguel's Avatar
    11-11-2016, 11:10 PM
    I'm noticing that when while playing, there is a loss in volume that occurs intermittently. All connections are good, the jack is brand new and I've...
    1 replies | 134 view(s)
  • Caleb_Elling's Avatar
    11-11-2016, 01:51 PM
    Hey Graham, I sent you that diagram. Were you able to locate a replacement pickup?
    1 replies | 161 view(s)
  • weeggordon's Avatar
    11-10-2016, 12:04 PM
    Hi there. The under saddle transducer stopped working and i wanted to replace it myself. Although ive fitted element systems in two of my guitars,...
    1 replies | 161 view(s)
  • jiff 41's Avatar
    11-10-2016, 12:12 AM
    jiff 41 replied to a thread Anthem - noise in Main Forum
    I agree with this 100%, It's the best I've ever experienced!, & I'm REALLY happy with the products I have (Anthem full & Venue) ;)
    11 replies | 546 view(s)
  • Kluszewski's Avatar
    11-09-2016, 02:04 PM
    Kluszewski replied to a thread Anthem - noise in Main Forum
    I am very grateful for such a settlement of the case. Quickly and precisely. The system will be replaced. Customer service at the highest level.
    11 replies | 546 view(s)
  • Caleb_Elling's Avatar
    11-08-2016, 10:27 AM
    Caleb_Elling replied to a thread Anthem - noise in Main Forum
    Our web team has been made aware of the issue. I've been told that they're looking into it.
    11 replies | 546 view(s)
  • Kluszewski's Avatar
    11-08-2016, 08:33 AM
    Kluszewski replied to a thread Anthem - noise in Main Forum
    There is a technical problem with this forum, every now and then I transferred to some strange website.
    11 replies | 546 view(s)
More Activity