PDA

View Full Version : Batter wont stay in!



Chuck Day
04-21-2013, 08:56 AM
I have an original Composite Acoustics Bluegrass Performer Guitar with an L.R. Baggs, iBeam pick-up system. Recently the spring loaded battery compartment will not stay clipped in. I have had to tape it down with gaffer's tape to make it work. I noticed the little "tit" that holds the Battery holder in had broken off. Is there any way to order another one of the Battery holders? I love he way the guitar sounds with this system and since it has been cut to accommodate this system I would hate to have to replace it. Thanks in advance for any info and help !
Chuck Day

Caleb_Elling
04-22-2013, 07:49 AM
Hi Chuck,
If you email me your address at [email protected], I'll see what I can find for you.

The Acoustic Guitar YYC
08-23-2013, 02:35 PM
Caleb;
I believe I have the same problem. This is a CA sold a couple of years ago, I'm sure it's in the main part of the unit and not the 'box'. Any joy for me? If it comes down to it, will the new pre-amp fit the old holes? Can I order a new pre-amp assembly?

Thanx.

Mike MacLeod
The Acoustic Guitar, Calgary
www.acousticguitar.net




Hi Chuck,
If you email me your address at [email protected], I'll see what I can find for you.

Caleb_Elling
08-23-2013, 02:58 PM
Mike,
I replied to the email that you sent to me. If you need anything else, let me know.

timpane
08-29-2013, 03:25 AM
This is a CA sold a couple of years ago, I'm sure it's in the main part of the unit and not the 'box'. Any joy for me?

Caleb_Elling
08-29-2013, 08:09 AM
Hi Timpane,
Let me clarify, before I answer your question.

You are having a problem with your battery drawer staying in, but you think that it's a problem with the preamp and not the battery drawer- is that right? If so, what in the preamp do you suspect is the problem?

The Acoustic Guitar YYC
10-13-2013, 03:19 PM
Sorry, Caleb. I don't seem to have your response. Can you try again?

Caleb_Elling
10-14-2013, 07:39 AM
Sorry, Caleb. I don't seem to have your response. Can you try again?
If possible, email me a picture of your preamp at [email protected] I'll see what I can do from there.