PDA

View Full Version : Anthem SL endpin pre-amp loose?



Steve Gullick
05-14-2013, 01:01 AM
Hi from sunny UK.

I have just fitted one of the above into my Fylde Falstaff (was amazed just how easy it was to fit) but I have a couple of issues - firstly, the endpin jack seems to be made in two halves that screw together, should these be screwed tight together or left loose as it is at present? Second, I now have a slight buzz from my d string (only the d string) I don't think it is fret buzz, could it be a wire inside not secured properly or could it be related to the endpin jack/pre-amp not being screwed tight together?

Help

Thanks

Steve

Caleb_Elling
05-14-2013, 09:22 AM
Hi Steve,
It sounds like there may be a few things going on here. If you email me directly at [email protected], I can help you more quickly.

Steve Gullick
05-15-2013, 01:33 AM
Hi Caleb

I think I may have fixed it, I took it out l;ast night and had a good look and it appears that the endpin/pre-amp that I thought was in two peices is actually a screw on cover that was not 'screwed on' properly, I have tightened it up and put it ball back together and although I have not tested it with an amp yet, all now looks good and I think the buzzing has stopped.

Thanks for your very porompt reply though - gives me a lot of confidence in the product.

Caleb_Elling
05-15-2013, 09:08 AM
Good to hear, Steve. I though that the issue may have been coming from the loose endpin.

Steve Gullick
05-15-2013, 09:22 AM
Actually, assuming this sounds as good as I expect it to through an amp, I intend to get a M1a for my HD28V as the quality of the product is superb and your amazing fast response to my enquiry yesterday was astonishing!

Thanks

Caleb_Elling
05-15-2013, 12:12 PM
I've been using LR Baggs products, myself, for about 10 years, and I'm still using some of the same stuff now. Everything has held up really well.

I'm glad that I could help!