PDA

View Full Version : I beam mixing system problem



jimtzu
12-25-2013, 09:30 PM
hi... I've got a Babicz guitar with a pre-installed I beam mixing system setup that up to now has worked great. lately the I beam part of the system has been going in and out. is there anything that can be done to fix this?
thanks

Caleb_Elling
12-26-2013, 08:23 AM
Hey Jimtzu,
It's hard to say for sure if that is something that can be fixed. The iBeam mixing system (or iBeam onboard) has been out of production for some some now.

When the iBeam goes out, does the volume just drop? or are there other symptoms? Anything you can tell me will help.

jimtzu
12-26-2013, 11:14 AM
Hey Jimtzu,
It's hard to say for sure if that is something that can be fixed. The iBeam mixing system (or iBeam onboard) has been out of production for some some now.

When the iBeam goes out, does the volume just drop? or are there other symptoms? Anything you can tell me will help.

Hi Caleb.. the piezo seems to be doing ok.. the Ibeam pickup is intermittent. the way i notice is that all the sudden the volume gets louder because the Ibeam kicks back in. i'm hoping it might be a connection problem or something easy. since it's built into the Babicz it has it's own controls on the side of the guitar where the battery is also located. it's a great pickup, perfect for recording straight into the board. i hope that helps with the descrtipion... if not let me know what else would be of use.
i appreciate the response.

Caleb_Elling
12-26-2013, 11:51 AM
Is there anything that you can do to initiate the issue, or is completely random?

jimtzu
12-26-2013, 12:01 PM
plugging into the end pin can be a bit noisey. i'm just pin pointing the problem the last week or so. i didn't know anything was wrong until i heard the signal getting louder when, apparently, the ibeam pickup kicked back in.

Caleb_Elling
12-26-2013, 12:58 PM
Have you changed the battery recently?

And does the position of the mix knob change anything?

jimtzu
12-26-2013, 10:21 PM
the battery was the first thing i thought of and switched it out but no change. the mix knob doesn't seem to have any change. are you thinking along the lines of it being a dirty pot? since it does go in and out could it be a connection at some point? (sorry for the long delay in response, i work eves and had to go to work).

Caleb_Elling
12-27-2013, 07:57 AM
If the mix is set to the Element pickup side, then the iBeam should not be heard at all, working or not. If you are still loosing volume at this setting, then there is likely something in the preamp that is going bad.

You can email me at [email protected], if you would like to go over your options from here.

anglenasalt
01-28-2014, 08:28 PM
It's built into the Babicz it has it's own controls on the side of the guitar where the battery is also located. it's a great pickup, perfect for recording straight into the board. i hope that helps with the descrtipion...