PDA

View Full Version : Anthem phase button broken



dan
06-18-2011, 08:25 PM
Hello all,

I pulled my guitar out of the case the other day to use it and noticed that the phase button had nearly come out of my anthem system I had installed in my guitar in November. It was fine, to the best of my knowledge, when I put the guitar in the case the previous time but when I pulled it out this time it was like the button was broken and about to fall out. It is very loose and it will not stay in when you push the button in. The phase still works the best I can tell but it is sometimes hard to get it to engage because it is so loose. Has anyone else had this problem and what can I do to fix it? I am not rough on my guitars but this is my main guitar and it gets used live whenever I play live and also for practice.

Thanks

Dan

Justin Rucker
06-20-2011, 09:13 AM
Hi Dan,

Sorry to hear that your Anthem has a broken phase button. Please contact our Tech Support (805) 929-3545 and we will arrange a replacement for your Anthem right away.

Caleb_Elling
06-20-2011, 09:28 AM
Hi Dan,
My name is Caleb and I am part of the Tech Support staff here at L.R. Baggs.

We have run into this Phase Button issue a handful of times, so if you are interested in getting a replacement I would be happy to help you. The phase button should not cause any rattle or extra noise in the amplified sound, so you can continue to use it if you decide not to replace it.

If you would like to have your preamp replaced, you can call me at (805)929-3545 ext. 121. I can issue you a Return Authorization number and we'll send you a replacement preamp at no charge.

dan
06-20-2011, 10:19 AM
Thanks yall! I will be calling in a short while to get that RA # and get the preamp switched out.

LR Baggs customer service and tech support is top notch! Thanks again!

wildfsh
02-23-2012, 03:11 PM
My phase button selfdestructed on my anthem preamp. Just like the other post, I opened my case and the phase button was hanging down almost out of the preamp enclosure. The guitar started making a electronic buzz sound when string is plucked. I think it is coming from the inside the preamp. When I turn the blend to the element pickup the buzz stops. I also noticed that buzz stops if I I hold guitar at a certain angle. I will be calling customer service to find a solution.

Bryan McManus
02-28-2012, 12:49 PM
Hi Wildfish,

Thank you for calling and arranging to send those items in for testing and repair or replacement.