Results 1 to 3 of 3

Thread: T bridge->GigPro->board. Huge buzz when switch OPEN.

Hybrid View

  1. #1
    Junior Member
    Join Date
    Apr 2014
    Location
    Western Canada
    Posts
    1

    T bridge->GigPro->board. Huge buzz when switch OPEN.

    Hello there,

    In my Ibanez Artcore I have an LR Baggs T Bridge, running into an LR Baggs Gig Pro preamp. I have a 1/4" jack for the acoustic side, and another separate one for the existing humbuckers. I want to keep the systems completely separate.

    However, I want to use a Strat style 5 way switch(which is really a 3 way, 2 pole) to switch between the humbuckers and the T bridge. The humbuckers are on one side of the switch, and the T bridge is on the other. I simply have the two wires from the T Bridge volume control interrupted on their way to the 1/4" jack, and attached to the last two pins of the switch.

    When the T bridge is closed-in operation-it sounds fantastic, with no noise, or hum at all. But When the switch for the T bridge is OPEN, it makes a horrendous, distorted, buzzing sound that is so hot it pins the meters all the way. It's certainly not like any 60 cycle hum I've ever heard. I have tried it on 2 different systems and the results are identical. What am I doing wrong and how can I correct this?

    Thank you for your time.

    Cheers
    Keith
    Last edited by took-the-red-pill; 04-02-2014 at 05:58 PM.

  2. #2
    Hi Keith,

    Does this occur when you use only one of the two outputs from the guitar or does it require you to be using both at the same time?

    Does touching metal in the ground circuit, such as the output jack hardware, either reduce/eliminate the buzz or does it get worse? I guess that's to ask, if it doesn't sound like 60Hz hum, does it respond to grounding tests as would a compromised shield. Inversely, does touching the T-Bridge make the noise less or more?

    You mentioned keeping the systems separate and with their own outputs. Does the 5-way switch have two outputs and serve as an either/or for two totally independent signals? If they are joined, it can work against your intended result.

    Please reply with clarification.

  3. #3
    Junior Member
    Join Date
    Mar 2012
    Posts
    25
    Sorry to butt in, but when you get the system working, I'd love to hear what it sounds like. I've been thinking about installing a T-Bridge on my Artcore AF-85 for a while now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •