Results 1 to 2 of 2

Thread: Venue DI Tuner Issues

  1. #1
    Junior Member
    Join Date
    Sep 2014
    Posts
    1

    Venue DI Tuner Issues

    I've been having issues with the Venue DI tuner not consistently turning on when I push the button. It will work one moment and then the next time I try and tune the button will mute the guitar but the tuner won't activate. My solution to this has been to press the button on and off until the tuner activates. Some times it can take as many as 10 - 20 "on/offs" before it illuminates and tuning becomes possible. Ive tried different chords, battery changes in the Dual Source Pickup, volume on the pickup, and making sure the Venue DI is plugged into an outlet as well as keeping the battery in the unit fresh. The violinist in the band I play with has the same issue. It always works eventually but when you're tuning in-between songs the delay can become a bother. Any ideas? Thanks.

    Ryan

  2. #2
    Hi Ryan,

    Thanks for your inquiry.

    We've had a few instances of this symptom that would present itself in the situation you described. It's when the tuner has timed out but the signal remains muted and the player then wants to tune so they quickly step twice on the footswitch to turn the mute off and then reengage the tuner/mute.

    A few players have simply clicked too fast. If you give an extra half-second between the two clicks, it should reengage the tuner reliably.

    If adding a little time between clicks does not solve the issue, please let me know.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •