Results 1 to 7 of 7

Thread: Lyric feedback problems

  1. #1
    Junior Member
    Join Date
    Apr 2014
    Posts
    4

    Exclamation Lyric feedback problems

    Hello,

    I bought a Lyric microphone system about 3 months ago and had absolutely terrible issues with it randomly cutting out. After some work with the support team we determined that is was a faulty system and I was sent a brand new one. I had the new one installed into my Martin D-28 this last week and I'm still having issues with it. When it is initially plugged in it sounds absolutely wonderful. The problem is that when it sits for too long a quiet, high pitched squeal will start to occur and it will increase in volume exponentially until it makes your ears bleed. At first I thought it was because I was standing directly in front of a monitor which was playing 7 guitars through it. However, later in the week I was at a smaller venue where it was just me, a piano, and two vocalists. It preformed flawlessly through practice but just to be safe I turned the guitar off at the board after practice. When I turned my guitar back on for the performance it immediately squealed and I ended up having to use a mic in front of it for the rest of the set. I absolutely love the way that the Lyric sounds but I need it to have my complete trust and confidence that it won't be so finicky.

    Thank you for your help

  2. #2
    Hey sdbuggyboys,
    In my experience, high pitched "squeal" comes from having the "Mic Presence" control set too high. I've encountered that same problem in a few different guitars, and lowering that control has fixed it in every case.

    You don't want to lower it so much that it makes the guitar sound dull, but there should be a good in-between position that will work for you. That control is pretty sensitive, so be careful. Small adjustments can make a big difference.

    I hope that helps!

  3. #3
    Junior Member
    Join Date
    Apr 2014
    Posts
    4
    Thanks so much, I will definitely try that out!

  4. #4
    Junior Member
    Join Date
    Apr 2014
    Posts
    4
    OK, so I tried changing the mic presence today when it started squealing again and it didn't work at all. Could some wires be crossed making a rudimentary antenna? But then how would that explain the fact that I played for 30 minutes with no problems whatsoever? I've heard these mics before and I know they are good and reliable, but I need to be able to not worry about it once I plug it in. I bought it because, when its working, it sounds crystal clear but I need it to be reliable as well. Thanks for the help!

  5. #5
    Ok,
    The only other time were I have encountered that issue, and where it only occurred after 10-20 minutes of playing, the battery in the Lyric was getting low. If you have already changed the battery with a known-good one and the issue still occurs, let me know. If that's still a problem, email me at [email protected], and I'll see what I can do to help you further.

  6. #6
    Junior Member
    Join Date
    Apr 2014
    Posts
    4
    OK, I will give that a try and let you know, thank you so much again.

  7. #7
    Junior Member
    Join Date
    Aug 2014
    Posts
    8

    633

    Quote Originally Posted by sdbuggyboys View Post
    OK, I will give that a try and let you know, thank you so much again.
    I'am curious about this issue. It was solved with the battery replacement?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •