Results 1 to 2 of 2

Thread: Presence control has no effect

  1. #1

    Presence control has no effect

    Hello, this is my first post on this forum. I have been using a Lyric system in a D-18VS for a few months and decided to carefully move it to a D-18GE, trying not to stress any of the components. The controls seem a bit strange now. It seems as though the volume control comes full on with just a slight rotation and then has no effect through the rest of the range of rotation and the presence control makes no change whatsoever in the trebles. I changed the battery and its still the same. I would appreciate any ideas of what it could be?

    Scott
    Last edited by caballeros59; 06-18-2014 at 03:36 PM.

  2. #2
    Hi Scott,

    Thanks for bringing this to our attention.

    If the symptoms are related to the control unit and occurred after it was removed from one guitar and installed into another, the control unit's wire connection may have been damaged when it was detached from the soundboard.

    It may be a good idea to manipulate the wire where it exits the volume control housing. Observe if it affects the behavior of the volume and presence controls.

    If you get a repeatable change in conditions or control behavior from moving the wire at that location, that connection should be reparable. If you aren't able to confirm the issue, it can be sent to LR Baggs for testing and service.

    Please reply or call 805-929-3545, ext. 111, to let me know what you find.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •