Results 1 to 6 of 6

Thread: Venue DI "overdriving"??

Hybrid View

  1. #1

    Venue DI "overdriving"??

    I purchased a Venue DI from eBay a couple months ago and have had some consistent problem with levels. For a while I didn't know if it was something I was doing or maybe settings on my mixer. But I recently used the DI through someone else's PA and it did the same thing.

    So, I have the gain set somewhere between 1 and 2. And I can see on the DI itself that the signal is registering with only one green light, so the level there is fine. And the gain on the mixer is only halfway or so. Yet at least 4 or 5 times at every single gig the mixer will cut out because the level keeps spiking. Like I said, I wasn't sure for the longest time if it was something I was doing. But I recently played through someone else's gear and it quickly got to the point that I had to unplug it because it was overdriving the channel. The boost was not on so it wasn't that. I really love the DI and don't want to get rid of it so I guess I need to know what my options are.

  2. #2
    Hi Busty,

    I can say the behavior you described is out of the ordinary.

    When you mention the gain at between 1 and 2, do you mean 1 and 2 o'clock or between the first and second lines above the full counter-clockwise position?

    If you are using the Venue DI's 1/4" output, does the overdriven sound remain when you reduce the Venue's output volume?

  3. #3
    Quote Originally Posted by Bryan McManus View Post
    Hi Busty,

    I can say the behavior you described is out of the ordinary.

    When you mention the gain at between 1 and 2, do you mean 1 and 2 o'clock or between the first and second lines above the full counter-clockwise position?

    If you are using the Venue DI's 1/4" output, does the overdriven sound remain when you reduce the Venue's output volume?
    The gain is between the 1st and 2nd lines. Very low.

    I'm using the XLR output.

  4. #4
    I'm going to use it tonight again with my own stuff and see if I can mess around with it. I'll let you know something tomorrow.

  5. #5
    I used it last night and no problems. Maybe it's something I'm doing. I will say that the problem usually happens when I'm at pretty high volume overall. So I'll fiddle with it this week in the garage and see if I can figure it out. Thanks.

  6. #6
    Hi Busty,

    That is curious. I'll be interested in knowing if a symptom reoccurs.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •