Results 1 to 2 of 2

Thread: Very short battery life in a Dual Source

Hybrid View

  1. #1
    Junior Member
    Join Date
    Oct 2011
    Posts
    1

    Very short battery life in a Dual Source

    I have a '71 Epiphone Jumbo box and a '95 Martin D35, both with Dual Source systems that were professionally installed several years ago. I run these these instruments (one at a time) into a Venue pedal with output via XLR into FOH. I play both of these guitars several times/week at shows or rehearsal and have had no problems until a couple weeks ago when the Epiphone started requiring a fresh battery each evening that I used it. Every time that I put a fresh 9V battery into the guitar (daily, unfortunately), the Epi is restored to it's fabulous amplified sound. By the end of a 2 hour show, the soundman is struggling to get enough clean gain from the Epiphone that I have to switch to the D35. The next morning I put a fresh 9V into the Epi and she's back to full strength, only to repeat the 2 hour cycle again that evening. I have no problems when I use the D35, and the battery life lasts for months (as the Epiphone did until recently). I've put a VOM across the battery; the new battery registers 9.3 - 9.5V and after the evening show, it's running around 8.5V or less. I've gone thru multiple packages of batteries, ruling out a bad batch. Any suggestions as to a remedy, short of replacing the entire Dual Source system in the Epi?

  2. #2

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •