Page 12 of 17 FirstFirst ... 21011121314 ... LastLast
Results 111 to 120 of 168

Thread: LR Baggs Technical Support On The Forum

  1. #111

  2. #112
    Junior Member
    Join Date
    Feb 2013
    Posts
    1
    I recently installed an X-bridge and CTRL-X in a Jazzmaster build. By recently, I mean this morning before work. I love it! It sounds exactly as I had hoped. I have 2 questions, and at least the first one is probably stupid. When using the blend pot, the volume on 1 gives me about a 50:50 blend between mags and piezo. On 10 I get straight piezo. Assuming that the pot should sweep between pure mags to pure piezo, did I possibly wire something incorrectly? I haven't had the opportunity to check yet, but is this potentially an issue with the setting on the internal trim pot?

    Also, I purchased the bridge new from an ebay seller a year ago, and I noticed this weekend that it was shipped for some reason without the tremolo arm. I have not been able to fit any of my other tremolo arms to the bushing. A USA Fender arm is too big, and a cheap Proline GC part is too small. What size tread will fit in this bushing?

    Thanks.
    Last edited by Waygorked; 02-27-2013 at 07:51 AM.

  3. #113
    The blend issues that you are experiencing is completely normal. The way that the components are designed and assembled makes it impossible to get full isolation without using the toggle-switch. So your bridge is functioning correctly.

    For your new bridge, did you get a US Standard or the Vintage bridge?

  4. #114
    Junior Member
    Join Date
    Mar 2013
    Posts
    3
    When installing my Lyric, I discovered there was very little room to install the mic centered below the saddle. I had to position the mic to clear the bridge pins and the string ball ends and I just barely succeeded, which put the two ends of the plastic portion of the mic up against the top bracing. Will the plastic of the mic touching here have an effect on the functioning and sound reproduction of the mic?

    Also, my cable plugs are very tight and difficult to insert into the Lyric preamp jack. They fit smoothly and with 3 easily felt and heard clicks in the Para DI and my Fishman amp, but these same cables must be pushed hard to get them inserted all the way into the Lyric jack. The gold plating on the plugs won't last long. Is this normal for the Lyric preamp, or do I have an anomaly? I'm hoping it's an anomaly as it's hard to imagine this being normal. I really want this to work. I purchased the Lyric last week.
    Last edited by Dave Shanks; 03-04-2013 at 08:37 PM.

  5. #115
    Hi Dave,
    The mic touching the braces is mostly a concern because some notes from the guitars will vibrate those braces and cause a rattle in the mic. This can sound like low-level distortion in the amplified signal. So if you have to put the mic behind the bridge pins, assuming there's room on the bridge plate, that would be a safer option.

    As far as the jack: some of our jacks are a little tighter than others, but they do loosen up after about two weeks of regular use.

  6. #116
    Junior Member
    Join Date
    Mar 2013
    Posts
    3
    So positioning the mic behind the bridge pins will be ok sound-wise? It does not have to be directly under the saddle? I do have plenty of room on the bridge plate to mount the mic behind the bridge pins. This will position the mic about 2" away from the saddle. And thank you for the help on these issues. It's nice to have quick and reliable supoport from a manufacturer
    Last edited by Dave Shanks; 03-05-2013 at 10:14 AM.

  7. #117
    Putting the mic behind the pins is fine. I've done several installations where there was not sufficient room in front of the pins. I've placed the mic in front, behind, on the top itself in front and behind the bridge plate. The tone varies slightly depending on the placement, but you will get the best sound quality if you place it on the bridge plate.

  8. #118
    Junior Member
    Join Date
    Mar 2013
    Posts
    3
    Thanks for the advice.

  9. #119
    Junior Member
    Join Date
    Mar 2013
    Posts
    2
    I just came came form a trip and realized I lost the whammy bar on my bridge (electric)! Please somebody direct me where I can find one, I don't care how much it cost!!! I needed! Pease help!! Tx in advance!

  10. #120

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •