Results 1 to 5 of 5

Thread: M80 battery problems

  1. #1
    Junior Member
    Join Date
    Aug 2012
    Posts
    3

    M80 battery problems

    I believe that we were the 1st band in the UK to get the M80 pick up, so have had it a little while now. It's been great up until a few weeks ago when we turned up at a gig to find the battery flat. In the last two weeks we have fitted two battery's and now the 2nd one is flat. This last week we have even removed the pickup to eliminate the lead being the problem.

    Before I return it to the shop does anyone know if this is this a known problem with a simple fix?

  2. #2
    Hello Mark,
    Sometimes the strapjack can develop a short between the ring and sleeve in the cable or jack, causing the preamp to stay on all of the time. If that is the case, you would just need a replacement strapjack harness. The cable can be easily tested for a short at most guitar repair shops.

  3. #3
    Junior Member
    Join Date
    Aug 2012
    Posts
    3
    I thought that, especially because when we insert the 1/4 jack we have to then pull it back out 1/4 inch or we get no feed to the mixer. This week though I've unplugged the strap jack harness from the pickup before fitting the 2nd battery. The battery light was on 4 when I fitted it but fell to 2 by the next day. Saying that though the 2nd battery has now been in 5 days and is still showing 2 lights.

    I'll check for continuity with my AVO and see what happens.

    Mark D

  4. #4
    Junior Member
    Join Date
    Aug 2012
    Posts
    3
    There is no continuity in the strap jack harness so I think it rules that out.

  5. #5
    Since you find no short between RING and GROUND in the output harness, the way to test for the same in the pickup's output jack is to plug the harness back into the pickup, plug a TRS cable into the harness and test for a short between RING and GROUND on the other end of that TRS cable. Since there is no such short in the harness, it should reveal if there is one in the pickup.

    If you find no short there either, the next thing to do would be to check the DC current flowing in the battery circuit when the internal preamp is on. If you can read the DC current in when the pickup is on and, also important, if there is current when the circuit should be off.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •