I am very defeated by the feedback that is occuring from my new SL Anthem pickup. I have tryed everything including installing it into another guitar to eliminate the actual guitar being the cause. I run it through the Para DI into the mixer. I have tried the TruMic adjustment in every postition, all on right through to Full off. It does adjust but without the Tru mic on sound is very muffled and not so desirable, set it at half way and it will pick up your dijestive system! I have made sure to keep the UST wire clear from others and clear from soundboard from the point it leaves the underbridge.

I have a GS mini Taylor acoustic that I tryed it in with the same results. This little Taylor comes with an optional 'ES Go' Passive sound hole pickup, so long as I run it through the Para DI this little Taylor 'ES Go' pickup does a fine job for its cost. After reading not a thing bad about feedback with the Anthem infact quite the opposite.....all raiving reviews, I am left feeling like there must be something wrong somewhere?. currently I have given up
and just use the little Taylor ES Go pickup, it seems very resistent to feedback and powered through the Para DI it pumps out great Acoustic sound. My other big body acoustic I have to leave as a straight acoustic unless someone can give some advise on what is wrong, I am looseing motivation installing then uninstalling....strings off, strings on.... you know what I mean. However if there is sound advice that makes good sence enough for me to it again I'm there !