Results 1 to 6 of 6

Thread: Para DI MAJOR FAIL

Threaded View

  1. #1
    Junior Member
    Join Date
    Jul 2013
    Posts
    4

    Para DI MAJOR FAIL

    So its Sunday, on the schedule is home church in the morning, 5th Sunday is all music lunch in the fellowship hall, then 45 miles away to do a homecoming singing at another church. I get to the morning service.. pull out mandolin and plug in my trustee L.R. Baggs Para Acoustic D.I i've been using faithfully for a bout 4 years. and my mandolin comes in loud and clear through the sound system.... but wait....it sounds like crap! I go to adjust the eq settings....no difference! I turn the volume knob down... still loud and crappy! I pull the battery out ... still loud and crappy! The signal is passing straight through even with the battery OUT! I move to the other side of the stage and plug in a different XLR cable..same thing! I had to miss the lunch and run 30 miles home to get my presonus EQ3B unit and 30 miles back before the bus pulls out for the singing. So .. anyone? Any idea what happened? This came straight out of nowhere, no signs of trouble the last time I used it and it never left my gig bag between uses. btw.. I tried using a brand new battery hoping that was the trouble since it acted the same with the battery out, maybe that just meant the battery was dead. New battery made no difference.
    Last edited by pickinpete; 07-01-2013 at 07:36 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •