Results 1 to 7 of 7

Thread: problem with my Lyric

  1. #1
    Junior Member
    Join Date
    Aug 2013
    Posts
    2

    problem with my Lyric

    My Lyric is performing intermittently. Sometimes it works (and sounds great) then often it will just cut out (no sound). It worked great the first couple of months but is becoming progressively worse and I never know when it will work.

    I have pulled the system out, ensured a good battery, wiggled a little bit to check for loose wires but cannot get it to work now.

    I know it is with the system because I have tried plugging directly into a small amp with a known good cable and amp.

    Any suggestions? I had hoped exchanging would be a possibility but am about a month past Musician's Friend's return date, plus I did not realize that installing it myself would void the manufacturer warranty. It was very easy to install.

    Thanks in advance for any help,
    Brad

  2. #2

  3. #3

  4. #4
    Junior Member
    Join Date
    Oct 2015
    Posts
    3
    Quote Originally Posted by bradbrooks View Post
    My Lyric is performing intermittently. Sometimes it works (and sounds great) then often it will just cut out (no sound). It worked great the first couple of months but is becoming progressively worse and I never know when it will work.

    I have pulled the system out, ensured a good battery, wiggled a little bit to check for loose wires but cannot get it to work now.

    I know it is with the system because I have tried plugging directly into a small amp with a known good cable and amp.
    I am reviving this thread because I am having the same problem with my 2 year old Lyric. Installed by my dealer. Has previously worked. Nothing has changed since this summer when it worked fine. Have tried new battery, multiple cables and amps. Have gotten it to work very sporadically for a short interval, then I begin to hear a quiet, low pitched rumbling before it finally quit completely.

  5. #5
    Junior Member
    Join Date
    Oct 2015
    Posts
    3
    Follow up. Brand new battery, good cord, tapping on Lyric microphone produces no sound.

  6. #6
    Administrator Caleb_Elling's Avatar
    Join Date
    Jun 2011
    Posts
    1,183
    I just replied to your email. Feel free to respond however you prefer.

    I usually get/answer my emails more quickly.

  7. #7
    Junior Member
    Join Date
    Oct 2015
    Posts
    3
    Quote Originally Posted by Caleb_Elling View Post
    I just replied to your email. Feel free to respond however you prefer.

    I usually get/answer my emails more quickly.
    Thank you!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •