Results 1 to 2 of 2

Thread: Para Acoustic DI + Kustom PA50?

  1. #1
    Junior Member
    Join Date
    Oct 2013
    Posts
    1

    Para Acoustic DI + Kustom PA50?

    Hi all.

    First time posting. Long-time reader.

    Tonight I took my new Kustom PA50 to a small gig and found that my (ancient) Para Acoustic DI would absolutely not work with it. It would draw power via XLR, but would produce no output via the DI XLR output. I swapped out cables to no avail. Battery was fresh. I wound up just taking it out of the chain and everything worked fine.

    Here's the kicker: when I got home, I tested it with my Mackie 1202 mixer, and the input monitor indicates that it's getting plenty of signal.

    So I guess I have two questions:

    1) How do you tell if your Para Acoustic DI is kicking the bucket?

    2) Has anyone used one of these with a Kustom PA50? I have a Lyric system installed in my guitar.

    3) Is this the excuse I need to pull the trigger on a LRB Venue?

    Thanks in advance for any thoughts/advice.

  2. #2
    It's hard to say if your DI is going out. I think that a few more tests would tell you if the issue was just a fluke, or if there was a bigger issue. I would recommend trying your Kustom and your Mackie, side by side with the same cables and other gear. If the Para DI really isn't working with the Kustom PA, that would be very strange. If you are running on a battery, I can't see any reason why the DI would work with the Mackie and not the Kustom.


    P.S.
    The Venue is pretty awesome. My acoustic gigs have never been easier

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •