Results 1 to 3 of 3

Thread: Problems with Sitar High Pitch Strings (chikaris) and Para DI

Hybrid View

  1. #1

    Problems with Sitar High Pitch Strings (chikaris) and Para DI

    Hi!

    I am using a new McIntyre transducer pickup on a Sitar.

    I have been running it through a very old (like 20 years!) DOD 16 Band Graphic EQ into an equally old Fender Princeton Chorus Amp.

    The overall sound was good, but the old equipment but the EQ had a small amount of noise and I was hoping to improve the sound with less noise by replacing the old EQ.

    The McIntyre recommends use of the Para DI, as does the website I bought the McIntyre from.

    One problem I have run into with the Para DI, though is that it get a very loud ugly "crunchy" distortion sound from the "Chikari" strings. These are three high pitched strings used for rhythm on the Sitar.

    I tried turning down the treble but it doesn't eliminate the distortion and dulls the main playing string instead. I also tried turning down the gain, but I would pretty much need to turn it off to get rid of the crunchy sounds.

    I also tried playing around with the Presence control, since the manual mentions it can be useful to get rid of hissing noises, even though this isn't really a hiss. But that doesn't help with the chikari crunch either.

    The manual says that the "notch" control can be used for EQ, so I tried that as well. But I hear no real difference whatever frequency I set it to or whether I boost or cut it.

    The crunch is definitely from the Para DI... if I unplug the McIntyre from the Para DI and plug directly into the amp, the "chikari crunch" goes away.

    Any ideas what I can do? Or is the Para DI just not capable of handling multiple loud high-pitched notes at the same time?

    I am assuming this isn't true, and its just a matter of some combination of controls -- but I just haven't been able to figure it out.

    Thanks!
    Stephen David
    Last edited by Stephen David; 06-04-2011 at 01:02 PM. Reason: clarification

  2. #2
    I reset everything back to 0 and started over. That got rid of the "chikari crunch" distortion. But I still have no idea what caused it... none of the settings I was using were excessive. So I would still appreciate if someone could give me an idea regarding what might have caused this so I could avoid it in the future. Thanks! Stephen David

  3. #3
    Input impedance can have something to do with this phenomenon. One large difference between the Para DI and the amplifier is in the input impedances. The Para DI's input impedance is way higher and therefor passes more of the pickup signal's low frequencies. These can be largely responsible for overdrive or distortion that is not there when the device is not in the signal chain.

    I am reluctant to agree the crunch comes from the Para DI. Rather I would say it is some artifact of the pickup signal that is being passed/boosted by the Para DI and sent on to the amplifier. You may be able to bring it back(for investigative reasons) by manipulating the gain, low frequency and notch controls.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •